C#学习教程:使用Firebird ado.net提供程序在客户端和服务器上请求的不兼容的线加密级别分享


使用Firebird ado.net提供程序在客户端和服务器上请求的不兼容的线加密级别

我正在使用C#测试连接firebird 3。 我使用的版本是最新版本:Firebird ADO.NET Provider 5.0。 但是当您建立连接时,会出现“客户端和服务器上请求的不兼容的线程加密级别”错误。“

在“ Firebird ADO.NET 4.10.0.0数据提供程序是否与Firebird 3.0配合使用? ”中,有一些建议可以在传统模型中启用身份validation或创建旧版用户。

但我的问题是,是否真的不支持5.0版Net Provider中的新SRP身份validation模型?

该问题本身与SRP无关,但Firebird .NET提供程序版本5.0.0.0仅添加了SRP支持,但尚未实现有线协议加密。 默认情况下,此有线协议加密依赖于SRP作为其会话密钥,但实施SRP并不意味着实现了有线协议加密。

Firebird 3默认需要加密,但由于Firebird .NET提供程序版本5不支持,因此会出现“客户端和服务器上请求的不兼容的线程加密级别”错误。 您需要通过编辑firebird.conf来配置Firebird 3以启用但不需要加密:

 WireCrypt = Enabled 

然后重启Firebird。

上述就是C#学习教程:使用Firebird ado.net提供程序在客户端和服务器上请求的不兼容的线加密级别分享的全部内容,如果对大家有所用处且需要了解更多关于C#学习教程,希望大家多多关注—猴子技术宅(www.ssfiction.com)

本文来自网络收集,不代表猴子技术宅立场,如涉及侵权请点击右边联系管理员删除。

如若转载,请注明出处:https://www.ssfiction.com/ckf/1031581.html

发表评论

邮箱地址不会被公开。 必填项已用*标注